Re: Re: [COMMITTERS] pgsql: Instead of trying (and failing) to allow <<label>> at the end of
Re: Re: [COMMITTERS] pgsql: Instead of trying (and failing) to allow <<label>> at the end of
От:
Tom Lane <tgl@sss.pgh.pa.us>
Дата:
David Fetter writes: > On Tue, Mar 02, 2010 at 11:02:54PM -0500, Jaime Casanova wrote: >> On Tue, Mar 2, 2010 at 8:53 PM, Tom Lane wrote: >>> Instead of trying (and failing) to allow <> at the end of a DECLARE >>> section, throw an error message saying explicitly that the label must go >>> before DECLARE. >> >> with the docs saying another thing, this couldn't be considered as a >> bug fix and therefore backpatchable > +1 for back-patching. No, I intentionally didn't back-patch that. The only benefit of the change is throwing a useful error message for questionable syntax. As against that we have the possibility of breaking code that works now, if someone's got an incorrectly-placed label that they're not actually referencing. I grant that that's not a very likely case; but the error that the message would help people fix isn't very likely either, as demonstrated by the fact that this never came up before. We shouldn't be making changes in the behavior of back branches for such things. regards, tom lane
Re: Re: [COMMITTERS] pgsql: Instead of trying (and failing) to allow <<label>> at the end of
От:
Tom Lane <tgl@sss.pgh.pa.us>
Дата:
Jaime Casanova writes: > On Wed, Mar 3, 2010 at 1:00 AM, Tom Lane wrote: >> No, I intentionally didn't back-patch that. The only benefit of the >> change is throwing a useful error message for questionable syntax. > then, maybe a fix in the docs of back branches? What's to fix? The documentation already makes it quite clear where you're supposed to put the label. I think documenting the code's actual behavior could only confuse people. regards, tom lane
Re: [COMMITTERS] pgsql: Instead of trying (and failing) to allow <<label>> at the end of
От:
David Fetter <david@fetter.org>
Дата:
On Tue, Mar 02, 2010 at 11:02:54PM -0500, Jaime Casanova wrote: > On Tue, Mar 2, 2010 at 8:53 PM, Tom Lane wrote: > > Log Message: > > ----------- > > Instead of trying (and failing) to allow <> at the end of a DECLARE > > section, throw an error message saying explicitly that the label must go > > before DECLARE. > > with the docs saying another thing, this couldn't be considered as a > bug fix and therefore backpatchable +1 for back-patching. Cheers, David. -- David Fetter http://fetter.org/ Phone: +1 415 235 3778 AIM: dfetter666 Yahoo!: dfetter Skype: davidfetter XMPP: david.fetter@gmail.com iCal: webcal://www.tripit.com/feed/ical/people/david74/tripit.ics Remember to vote! Consider donating to Postgres: http://www.postgresql.org/about/donate
Re: Re: [COMMITTERS] pgsql: Instead of trying (and failing) to allow <<label>> at the end of
От:
Jaime Casanova <jcasanov@systemguards.com.ec>
Дата:
On Wed, Mar 3, 2010 at 1:00 AM, Tom Lane wrote: > David Fetter writes: >> On Tue, Mar 02, 2010 at 11:02:54PM -0500, Jaime Casanova wrote: >>> On Tue, Mar 2, 2010 at 8:53 PM, Tom Lane wrote: >>>> Instead of trying (and failing) to allow <> at the end of a DECLARE >>>> section, throw an error message saying explicitly that the label must go >>>> before DECLARE. >>> >>> with the docs saying another thing, this couldn't be considered as a >>> bug fix and therefore backpatchable > >> +1 for back-patching. > > No, I intentionally didn't back-patch that. The only benefit of the > change is throwing a useful error message for questionable syntax. then, maybe a fix in the docs of back branches? OTOH, anyone that already had the docs downloaded will not benefit of that, but that is just as fair as if you don't update the server you don't get the last fixes ;) -- Atentamente, Jaime Casanova Soporte y capacitación de PostgreSQL Asesoría y desarrollo de sistemas Guayaquil - Ecuador Cel. +59387171157
Re: Re: [COMMITTERS] pgsql: Instead of trying (and failing) to allow <<label>> at the end of
От:
Jaime Casanova <jcasanov@systemguards.com.ec>
Дата:
On Wed, Mar 3, 2010 at 1:12 AM, Tom Lane wrote: > Jaime Casanova writes: >> On Wed, Mar 3, 2010 at 1:00 AM, Tom Lane wrote: >>> No, I intentionally didn't back-patch that. The only benefit of the >>> change is throwing a useful error message for questionable syntax. > >> then, maybe a fix in the docs of back branches? > > What's to fix? The documentation already makes it quite clear where > you're supposed to put the label. I think documenting the code's > actual behavior could only confuse people. > ah! yeah! sorry for the noise... it was just the need to say something else... ;) -- Atentamente, Jaime Casanova Soporte y capacitación de PostgreSQL Asesoría y desarrollo de sistemas Guayaquil - Ecuador Cel. +59387171157