Re: initdb fails to initialize data directory
От
Heikki Linnakangas
Тема
Re: initdb fails to initialize data directory
Дата
Msg-id
ed0e5651-a2ba-1ad7-cb86-0e8a68116e60@iki.fi
Ответ на
Re: initdb fails to initialize data directory (Alvaro Herrera)
Список
Дерево обсуждения
initdb fails to initialize data directory Nikhil Sontakke <nikhils@2ndquadrant.com>
Re: initdb fails to initialize data directory Alvaro Herrera <alvherre@alvh.no-ip.org>
Re: initdb fails to initialize data directory Heikki Linnakangas <hlinnaka@iki.fi>
Re: initdb fails to initialize data directory Alvaro Herrera <alvherre@alvh.no-ip.org>
Re: initdb fails to initialize data directory Michael Paquier <michael@paquier.xyz>
On 19/04/18 09:38, Alvaro Herrera wrote: > Nikhil Sontakke wrote: > >> Intrigued, on digging down further, this is happening because we are >> not using a long enough buffer to accept the output of "postgres -V" >> in the find_other_exec() function. In our case, we had used >> --with-extra-version option with configure which caused the output of >> "postgres -V" to go a little beyond the current "line" variable size. >> This caused the strcmp to fail leading to initdb refusing to >> initialize any data directories at all. > > Wow, that seems pretty silly nowadays. Agreed. Nitpick: using MAXPGPATH seems for the buffer size seems to wrong to me. We're not storing a path here. MAXPGPATH is 1024 by default, which seems fine, but I would've spelled it out directly as "line[1000]". - Heikki
В списке pgsql-hackers по дате отправления