Re: Could not create a tablespace - permission denied

Поиск
Список
Период
Сортировка
Искать
От
Graham Leggett
Тема
Re: Could not create a tablespace - permission denied
Дата
Msg-id
480A381D.3030908@sharp.fm
Ответ на
Список
Дерево обсуждения
Could not create a tablespace - permission denied Graham Leggett <minfrin@sharp.fm>
Re: Could not create a tablespace - permission denied Tom Lane <tgl@sss.pgh.pa.us>
Re: Could not create a tablespace - permission denied Graham Leggett <minfrin@sharp.fm>
Re: Could not create a tablespace - permission denied Tom Lane <tgl@sss.pgh.pa.us>
Re: Could not create a tablespace - permission denied Graham Leggett <minfrin@sharp.fm>
Re: Could not create a tablespace - permission denied "Joshua D. Drake" <jd@commandprompt.com>
Re: Could not create a tablespace - permission denied Graham Leggett <minfrin@sharp.fm>
Re: Could not create a tablespace - permission denied "Joshua D. Drake" <jd@commandprompt.com>
Re: Could not create a tablespace - permission denied Tom Lane <tgl@sss.pgh.pa.us>
Re: Could not create a tablespace - permission denied Tom Lane <tgl@sss.pgh.pa.us>
Joshua D. Drake wrote:

> I am pretty sure you are missing something. I can not reproduce your issue:

Do it like this:

- mkdir /tmp/foo
- chown user:user /tmp/foo
- edit /etc/group and add postgres to the group user
- attempt to access /tmp/foo as the user postgres, at this point a user 
logged in as postgres will be able to access the directory.
- attempt to create a tablespace on /tmp/foo, this will fail until 
postgresql is restarted, after which the attempt will succeed.

Regards,
Graham
--
В списке pgsql-admin по дате отправления
От: Tom Lane
Дата:
От: Joshua D. Drake
Дата:
FAQ