Re: How to recover when can't start database

Поиск
Список
Период
Сортировка
Искать
От
Tom Lane
Тема
Re: How to recover when can't start database
Дата
Msg-id
23357.1118421255@sss.pgh.pa.us
Ответ на
Список
Дерево обсуждения
How to recover when can't start database "L.Boldareva" <pg@pierro.dds.nl>
Re: How to recover when can't start database Scott Marlowe <smarlowe@g2switchworks.com>
Re: How to recover when can't start database Tom Lane <tgl@sss.pgh.pa.us>
Re: How to recover when can't start database "L.Boldareva" <pg@pierro.dds.nl>
Re: How to recover when can't start database Tom Lane <tgl@sss.pgh.pa.us>
Re: How to recover when can't start database "L.Boldareva" <pg@pierro.dds.nl>
"Colin E. Freas"  writes:
> 2005-06-07 16:02:38 EDTLOG:  statement: update pg_class set 
> reltriggers=foo.c from (select relname,count(tgrelid) as c from 
> pg_class,pg_trigger where pg_class.oid=tgrelid and relnamespace=2200 
> group by relname) foo;

I'm afraid that database is toast :-(.  You managed to overwrite
reltriggers in every row of pg_class, including all the system
catalogs, including some that absolutely positively cannot have
triggers ... like pg_trigger for instance.

-> try to open pg_class
   ... hmm, it says it has triggers
   -> try to open pg_trigger to read triggers
      ... hmm, it says it has triggers
      -> try to open pg_trigger to read triggers
         ... hmm, it says it has triggers
         -> try to open pg_trigger to read triggers

... recurse until out of stack space.

			regards, tom lane
В списке pgsql-admin по дате отправления
От: Lee Wu
Дата:
От: Lee Wu
Дата:
FAQ