Обсуждение: Size and size_t in dsa API

Поиск
Список
Период
Сортировка

Size and size_t in dsa API

От
"Ideriha, Takeshi"
Дата:
Hi, 

I'm trying to use DSA API and confused a little bit about $subject.

Some type of return value or arguments are defined as size_t
but others are as Size.

Example: 
- dsa_area *dsa_create_in_place(void *place, size_t size,
                    int tranche_id, dsm_segment *segment)

- Size dsa_minimum_size(void)

I'm confused because Size and size_t is virtually equal but 
they are mixed in dsa.c. At first I was thinking that there is
some distinguishing convention to use based on some context.

But according to this thread, which seems gone anywhere,
they are same. 
https://www.postgresql.org/message-id/CAEepm%3D1eA0vsgA7-2oigKzqg10YeXoPWiS-fCuQRDLwwmgMXag%40mail.gmail.com 
Are there still someone trying to this?
As a non-expert developer's opinion, I think mixing of Size and size_t makes difficult to understand source code.

===================================================
Takeshi Ideriha
Fujitsu Limited





Re: Size and size_t in dsa API

От
Thomas Munro
Дата:
On Thu, Sep 20, 2018 at 6:28 PM Ideriha, Takeshi
<ideriha.takeshi@jp.fujitsu.com> wrote:
> As a non-expert developer's opinion, I think mixing of Size and size_t makes difficult to understand source code.

Agreed.  Let's change them all to size_t and back-patch that to keep
future back-patching easy.  Patch attached.

-- 
Thomas Munro
http://www.enterprisedb.com

Вложения

RE: Size and size_t in dsa API

От
"Ideriha, Takeshi"
Дата:
>> As a non-expert developer's opinion, I think mixing of Size and size_t makes difficult
>to understand source code.
>
>Agreed.  Let's change them all to size_t and back-patch that to keep future
>back-patching easy.  Patch attached.

Thank you for the quick action. I'm happy now.
I confirmed English word Size in comment is kept as it is.

====================
Takeshi Ideriha
Fujitsu Limited

Re: Size and size_t in dsa API

От
Thomas Munro
Дата:
On Thu, Sep 20, 2018 at 10:13 PM Ideriha, Takeshi
<ideriha.takeshi@jp.fujitsu.com> wrote:
> >> As a non-expert developer's opinion, I think mixing of Size and size_t makes difficult
> >to understand source code.
> >
> >Agreed.  Let's change them all to size_t and back-patch that to keep future
> >back-patching easy.  Patch attached.
>
> Thank you for the quick action. I'm happy now.
> I confirmed English word Size in comment is kept as it is.

Pushed.  Thanks for the reminder about that.

-- 
Thomas Munro
http://www.enterprisedb.com