Re: Allow CLUSTER, VACUUM FULL and REINDEX to change tablespace on the fly

Поиск
Список
Период
Сортировка
От Alexey Kondratov
Тема Re: Allow CLUSTER, VACUUM FULL and REINDEX to change tablespace on the fly
Дата
Msg-id d177d8148f67bd8f6bad5fb0473879be@postgrespro.ru
обсуждение исходный текст
Ответ на Re: Allow CLUSTER, VACUUM FULL and REINDEX to change tablespace on the fly  (Peter Eisentraut <peter.eisentraut@enterprisedb.com>)
Список pgsql-hackers
On 2020-12-15 03:14, Justin Pryzby wrote:
> On Sat, Dec 12, 2020 at 01:45:26PM -0600, Justin Pryzby wrote:
>> On Sat, Dec 12, 2020 at 09:20:35AM +0100, Peter Eisentraut wrote:
>> > On 2020-12-11 21:27, Alvaro Herrera wrote:
>> > > By the way--  What did you think of the idea of explictly marking the
>> > > types used for bitmasks using types bits32 and friends, instead of plain
>> > > int, which is harder to spot?
>> >
>> > If we want to make it clearer, why not turn the thing into a struct, as in
>> > the attached patch, and avoid the bit fiddling altogether.
>> 
>> I like this.
>> It's a lot like what I wrote as [PATCH v31 1/5] ExecReindex and 
>> ReindexParams
>> In my v31 patch, I moved ReindexOptions to a private structure in 
>> indexcmds.c,
>> with an "int options" bitmask which is passed to reindex_index() et 
>> al.  Your
>> patch keeps/puts ReindexOptions index.h, so it also applies to 
>> reindex_index,
>> which I think is good.
>> 
>> So I've rebased this branch on your patch.
>> 
>> Some thoughts:
>> 
>>  - what about removing the REINDEXOPT_* prefix ?
>>  - You created local vars with initialization like "={}". But I 
>> thought it's
>>    needed to include at least one struct member like "={false}", or 
>> else
>>    they're not guaranteed to be zerod ?
>>  - You passed the structure across function calls.  The usual 
>> convention is to
>>    pass a pointer.
> 
> I think maybe Michael missed this message (?)
> I had applied some changes on top of Peter's patch.
> 
> I squished those commits now, and also handled ClusterOption and 
> VacuumOption
> in the same style.
> 
> Some more thoughts:
>  - should the structures be named in plural ? "ReindexOptions" etc.  
> Since they
>    define *all* the options, not just a single bit.
>  - For vacuum, do we even need a separate structure, or should the 
> members be
>    directly within VacuumParams ?  It's a bit odd to write
>    params.options.verbose.  Especially since there's also ternary 
> options which
>    are directly within params.

This is exactly what I have thought after looking on Peter's patch. 
Writing 'params.options.some_option' looks just too verbose. I even 
started moving all vacuum options into VacuumParams on my own and was in 
the middle of the process when realized that there are some places that 
do not fit well, like:

if (!vacuum_is_relation_owner(RelationGetRelid(onerel),
    onerel->rd_rel,
    params->options & VACOPT_ANALYZE))

Here we do not want to set option permanently, but rather to trigger 
some additional code path in the vacuum_is_relation_owner(), IIUC. With 
unified VacuumParams we should do:

bool opt_analyze = params->analyze;
...
params->analyze = true;
if (!vacuum_is_relation_owner(RelationGetRelid(onerel),
    onerel->rd_rel, params))
...
params->analyze = opt_analyze;

to achieve the same, but it does not look good to me, or change the 
whole interface. I have found at least one other place like that so far 
--- vacuum_open_relation() in the analyze_rel().

Not sure how we could better cope with such logic.

>  - Then, for cluster, I think it should be called ClusterParams, and 
> eventually
>    include the tablespaceOid, like what we're doing for Reindex.
> 
> I am awaiting feedback on these before going further since I've done 
> too much
> rebasing with these ideas going back and forth and back.

Yes, we have moved a bit from my original patch set in the thread with 
all this refactoring. However, all the consequent patches are heavily 
depend on this interface, so let us decide first on the proposed 
refactoring.


Regards
-- 
Alexey Kondratov

Postgres Professional https://www.postgrespro.com
Russian Postgres Company



В списке pgsql-hackers по дате отправления:

Предыдущее
От: Kyotaro Horiguchi
Дата:
Сообщение: Re: archive status ".ready" files may be created too early
Следующее
От: "iwata.aya@fujitsu.com"
Дата:
Сообщение: RE: libpq debug log