Rename libpq trace internal functions

Поиск
Список
Период
Сортировка
От Peter Eisentraut
Тема Rename libpq trace internal functions
Дата
Msg-id 575e4f9d-acfe-45e3-b7f1-7e32c579090e@eisentraut.org
обсуждение исходный текст
Ответы Re: Rename libpq trace internal functions  (Yugo NAGATA <nagata@sraoss.co.jp>)
Список pgsql-hackers
libpq's pqTraceOutputMessage() used to look like this:

     case 'Z':               /* Ready For Query */
         pqTraceOutputZ(conn->Pfdebug, message, &logCursor);
         break;

Commit f4b54e1ed98 introduced macros for protocol characters, so now
it looks like this:

     case PqMsg_ReadyForQuery:
         pqTraceOutputZ(conn->Pfdebug, message, &logCursor);
         break;

But this introduced a disconnect between the symbol in the switch case
and the function name to be called, so this made the manageability of
this file a bit worse.

This patch changes the function names to match, so now it looks like
this:

     case PqMsg_ReadyForQuery:
         pqTraceOutput_ReadyForQuery(conn->Pfdebug, message, &logCursor);
         break;

(This also improves the readability of the file in general, since some
function names like "pqTraceOutputt" were a little hard to read
accurately.)

Some protocol characters have different meanings to and from the
server.  The old code structure had a common function for both, for
example, pqTraceOutputD().  The new structure splits this up into
separate ones to match the protocol message name, like
pqTraceOutput_Describe() and pqTraceOutput_DataRow().
Вложения

В списке pgsql-hackers по дате отправления:

Предыдущее
От: Michael Paquier
Дата:
Сообщение: Re: Cleanup: remove unused fields from nodes
Следующее
От: Heikki Linnakangas
Дата:
Сообщение: Re: Feature request: schema diff tool