Re: default_transaction_isolation = serializable causes crash under Hot Standby

Поиск
Список
Период
Сортировка
Искать
От
Kevin Grittner
Тема
Re: default_transaction_isolation = serializable causes crash under Hot Standby
Дата
Msg-id
4F9A73EA0200002500047466@gw.wicourts.gov
Ответ на
Список
Дерево обсуждения
default_transaction_isolation = serializable causes crash under Hot Standby Robert Haas <robertmhaas@gmail.com>
Re: default_transaction_isolation = serializable causes crash under Hot Standby "Kevin Grittner" <Kevin.Grittner@wicourts.gov>
Re: default_transaction_isolation = serializable causes crash under Hot Standby Robert Haas <robertmhaas@gmail.com>
Re: default_transaction_isolation = serializable causes crash under Hot Standby Tom Lane <tgl@sss.pgh.pa.us>
Re: default_transaction_isolation = serializable causes crash under Hot Standby "Kevin Grittner" <Kevin.Grittner@wicourts.gov>
Re: default_transaction_isolation = serializable causes crash under Hot Standby Tom Lane <tgl@sss.pgh.pa.us>
Re: default_transaction_isolation = serializable causes crash under Hot Standby "Kevin Grittner" <Kevin.Grittner@wicourts.gov>
Re: default_transaction_isolation = serializable causes crash under Hot Standby Robert Haas <robertmhaas@gmail.com>
Tom Lane  wrote:
> Robert Haas  writes:
>> Or, maybe there's a way to throw an error when serializable mode
>> is used rather than when it's requested.
> 
> Couldn't we check and throw an error at the place in transaction
> startup where default_transaction_isolation is copied to the
> active variable?
Wouldn't that leave users stuck if the postgresql.conf set the
default to serializable?  Nobody would be able to start a
transaction, even to change the default, would they?  If that's the
case, we might as well refuse to start.
Robert's suggestion might be the least of the various evils.
-Kevin

В списке pgsql-hackers по дате отправления
От: Robert Haas
Дата:
От: Simon Riggs
Дата:
Сообщение: enable_indexonly
FAQ