Re: Moved postgres, now won't start

Поиск
Список
Период
Сортировка
Искать
От
Madison Kelly
Тема
Re: Moved postgres, now won't start
Дата
Msg-id
469BB9F6.1090507@alteeve.com
Ответ на
Список
Дерево обсуждения
Moved postgres, now won't start Madison Kelly <linux@alteeve.com>
Re: Moved postgres, now won't start Tom Lane <tgl@sss.pgh.pa.us>
Re: Moved postgres, now won't start Madison Kelly <linux@alteeve.com>
Re: Moved postgres, now won't start Madison Kelly <linux@alteeve.com>
Re: Moved postgres, now won't start Zoltan Boszormenyi <zb@cybertec.at>
Re: Moved postgres, now won't start Madison Kelly <linux@alteeve.com>
Re: Moved postgres, now won't start Tom Lane <tgl@sss.pgh.pa.us>
Re: Moved postgres, now won't start Alvaro Herrera <alvherre@commandprompt.com>
Zoltan Boszormenyi wrote:
> Do you use SELinux?
> Look for "avc denied" messages in the logs to see if it's the case.

   No, I don't (unless I missed it and Debian Etch uses it by default 
now). To be sure, I checked the log files and only say this:

2007-07-16 13:58:03 EDT LOG:  incomplete startup packet
2007-07-16 13:58:04 EDT LOG:  could not open temporary statistics file 
"global/pgstat.tmp": No such file or directory
2007-07-16 13:59:03 EDT FATAL:  could not open file 
"global/pg_database": No such file or directory
2007-07-16 13:59:04 EDT LOG:  could not open temporary statistics file 
"global/pgstat.tmp": No such file or directory
2007-07-16 14:00:03 EDT FATAL:  could not open file 
"global/pg_database": No such file or directory

   Over and over again. I tried shutting down postgresql again and got 
this at the shell:

# /etc/init.d/postgresql-8.1 stop
Stopping PostgreSQL 8.1 database server: main* pg_ctl: postmaster does 
not shut down
(does not shutdown gracefully, now stopping immediately)pg_ctl: could 
not send stop signal (PID: 19958): No such process
Insecure dependency in kill while running with -T switch at 
/usr/bin/pg_ctlcluster line 370.
(does not shutdown, killing the process)
  failed!

   And this in the logs:

2007-07-16 14:28:00 EDT LOG:  received fast shutdown request
2007-07-16 14:28:00 EDT LOG:  shutting down
2007-07-16 14:28:00 EDT PANIC:  could not open control file 
"global/pg_control": No such file or directory
2007-07-16 14:28:00 EDT LOG:  background writer process (PID 19960) was 
terminated by signal 6
2007-07-16 14:28:00 EDT LOG:  terminating any other active server processes
2007-07-16 14:28:00 EDT LOG:  all server processes terminated; 
reinitializing
2007-07-16 14:28:00 EDT LOG:  could not open file "postmaster.pid": No 
such file or directory
2007-07-16 14:28:00 EDT PANIC:  could not open control file 
"global/pg_control": No such file or directory
2007-07-16 14:28:00 EDT LOG:  could not open temporary statistics file 
"global/pgstat.tmp": No such file or directory


   Lastly, to be very sure, I tried grep'ing for that string with no 
results:

nicole:/var/log# grep "avc denied" * -Rni
nicole:/var/log#

   Thanks for the reply!

Madison
В списке pgsql-general по дате отправления
От: Madison Kelly
Дата:
От: Michael Nolan
Дата:
FAQ