Re: BUG #16595: Reads fail with "lost saved point in index" error after writes
От
Tom Lane
Тема
Re: BUG #16595: Reads fail with "lost saved point in index" error after writes
Дата
Msg-id
3355930.1598560763@sss.pgh.pa.us
Ответ на
Список
Дерево обсуждения
BUG #16595: Reads fail with "lost saved point in index" error after writes PG Bug reporting form <noreply@postgresql.org>
Re: BUG #16595: Reads fail with "lost saved point in index" error after writes Tom Lane <tgl@sss.pgh.pa.us>
Re: BUG #16595: Reads fail with "lost saved point in index" error after writes Jesse Kinkead <jesse@falkon.ai>
Re: BUG #16595: Reads fail with "lost saved point in index" error after writes Tom Lane <tgl@sss.pgh.pa.us>
Re: BUG #16595: Reads fail with "lost saved point in index" error after writes Jesse Kinkead <jesse@falkon.ai>
Jesse Kinkead writes:
> It sounds like this isn't a known problem,
Well, now it is :-). I'm just finishing up testing a patch.
> and that the only workaround
> might be just dropping the index. Hmm!
Single-column GIN indexes aren't subject to the issue, so maybe you
could work around it by replacing the multicolumn index with some
single-column ones?
Also, now that I've studied the code some more, the code path with
the issue is only hit for queries that use (a) partial match or
(b) an empty query that forces a full-index scan, similar to
"arraycol @> '{}'". That might explain how come the bug went
undetected for so long. I dunno if that info will help you dodge
the bug, but maybe.
If you can't find any acceptable workaround, another idea is to
build your own server version with the patch applied, to tide
you over until there's an official release with the fix. IMO
one of the main benefits of using open-source code is that that's
normally not very difficult.
regards, tom lane
В списке pgsql-bugs по дате отправления
От: Jesse Kinkead
Дата:
От: Jesse Kinkead
Дата: