[MASSMAIL]Cluster::restart dumping logs when stop fails

Поиск
Список
Период
Сортировка
Искать
От
Andres Freund
Тема
[MASSMAIL]Cluster::restart dumping logs when stop fails
Дата
Msg-id
20240406214439.2n4zf2w7ukhf7dsy@awork3.anarazel.de
Список
Дерево обсуждения
[MASSMAIL]Cluster::restart dumping logs when stop fails Andres Freund <andres@anarazel.de>
Re: Cluster::restart dumping logs when stop fails Daniel Gustafsson <daniel@yesql.se>
Re: Cluster::restart dumping logs when stop fails Andres Freund <andres@anarazel.de>
Re: Cluster::restart dumping logs when stop fails Daniel Gustafsson <daniel@yesql.se>
Re: Cluster::restart dumping logs when stop fails Andrew Dunstan <andrew@dunslane.net>
Re: Cluster::restart dumping logs when stop fails Daniel Gustafsson <daniel@yesql.se>
Re: Cluster::restart dumping logs when stop fails Andres Freund <andres@anarazel.de>
Re: Cluster::restart dumping logs when stop fails Daniel Gustafsson <daniel@yesql.se>
Re: Cluster::restart dumping logs when stop fails Andres Freund <andres@anarazel.de>
Re: Cluster::restart dumping logs when stop fails Daniel Gustafsson <daniel@yesql.se>
Hi,

I recently started to be bothered by regress_* logs after some kinds of test
failures containing the whole log of a test failure. E.g. in
https://buildfarm.postgresql.org/cgi-bin/show_log.pl?nm=serinus&dt=2024-04-06%2016%3A28%3A38

...
### Restarting node "standby"
# Running: pg_ctl -w -D /home/bf/bf-build/serinus/HEAD/pgsql.build/testrun/recovery/035_standby_logical_decoding/data/t_035_standby_logical_decoding_standby_data/pgdata -l /home/bf/bf-build/serinus/HEAD/pgsql.build/testrun/recovery/035_standby_logical_decoding/log/035_standby_logical_decoding_standby.log restart
waiting for server to shut down........................................................................................................................................................................................................................................................................................................................................................................... failed
pg_ctl: server does not shut down
# pg_ctl restart failed; logfile:
2024-04-06 16:33:37.496 UTC [2628363][postmaster][:0] LOG:  starting PostgreSQL 17devel on x86_64-linux, compiled by gcc-14.0.1, 64-bit
2024-04-06 16:33:37.503 UTC [2628363][postmaster][:0] LOG:  listening on Unix socket "/tmp/55kikMaTyW/.s.PGSQL.63274"



Looks like the printing of the entire log was added in:

commit 33774978c78175095da9e6c276e8bcdb177725f8
Author: Daniel Gustafsson 
Date:   2023-09-22 13:35:37 +0200

    Avoid using internal test methods in SSL tests


It might be useful to print a few lines, but the whole log files can be
several megabytes worth of output.  In the buildfarm that leads to the same
information being collected multiple times, and locally it makes it hard to
see where the "normal" contents of regress_log* continue.

Greetings,

Andres Freund


В списке pgsql-hackers по дате отправления
От: Andres Freund
Дата:
От: Alexander Korotkov
Дата:
FAQ