Re: [SQL] Problem wil TIMEZONE vs TIME ZONE

Поиск
Список
Период
Сортировка
Искать
От
Tom Lane
Тема
Re: [SQL] Problem wil TIMEZONE vs TIME ZONE
Дата
Msg-id
1471.1486569158@sss.pgh.pa.us
Ответ на
Список
Дерево обсуждения
[SQL] Problem wil TIMEZONE vs TIME ZONE Mike Wes <mikeewes@gmail.com>
Re: [SQL] Problem wil TIMEZONE vs TIME ZONE Tom Lane <tgl@sss.pgh.pa.us>
Re: [SQL] Problem wil TIMEZONE vs TIME ZONE Adrian Klaver <adrian.klaver@aklaver.com>
Mike Wes  writes:
> Can anybody clarify the following behaviour of pgsql? A Windows user in our
> project is not able to execute a create table command caused by the
> timestamp field log_created using 'TIME ZONE' (giant_log2), but must
> explict use 'TIMEZONE' (giant_log3). This is an issue while we use
> liquibase in our project. Any ideas why this is happening?

That sounds quite backwards.  TIMESTAMP WITH TIME ZONE is the SQL-standard
way of spelling the type name.  TIMESTAMP WITH TIMEZONE is not in the
standard and it's not accepted by Postgres either, as you can easily
prove by experiment:

regression=# create table foo(f1 TIMESTAMP WITH TIMEZONE);
ERROR:  syntax error at or near "WITH"
LINE 1: create table foo(f1 TIMESTAMP WITH TIMEZONE);                                     ^
regression=# create table foo(f1 TIMESTAMP WITH TIME ZONE);
CREATE TABLE

I think you must've had some confusion as to who issued which
command.
		regards, tom lane


В списке pgsql-sql по дате отправления
От: Adrian Klaver
Дата:
От: Herwig Goemans
Дата:
FAQ