E.2. Postgres Pro 9.6.5.1

Дата выпуска: 2017-08-31

E.2.1. Обзор

Этот выпуск основан на Postgres Pro 9.6.4.1 и PostgreSQL 9.6.5.

В число ключевых усовершенствований по сравнению с Postgres Pro 9.6.4.1 входят:

  • Модуль pg_pathman обновлён до версии 1.4.3. (См. Раздел F.35 и Подраздел F.35.1.1.) Эта версия по сравнению с 1.4.2 включает следующие усовершенствования:

    • Отключена опасная оптимизация команд UPDATE и DELETE для PostgreSQL 9.5.

    • Исправлено выполнение такого запроса: DELETE FROM single_table USING partitioned_table.

    • Исправлен вывод EXPLAIN INSERT INTO partitioned_table при включённом режиме подробных сведений.

    Полный список изменений можно найти на вики-странице pg_pathman.

  • Усовершенствована утилита pg_controldata, чтобы было возможным автоматическое обновление Postgres Pro с помощью скрипта pgpro_upgrade.

E.2.2. Миграция на версию 9.6.5.1

Процедура установки зависит от версии вашей текущей инсталляции.

Для обновления СУБД с версии Postgres Pro, основанной на предыдущем основном выпуске PostgreSQL, вы можете выполнить выгрузку/восстановление данных, применив pg_dumpall, или воспользоваться утилитой pg_upgrade. Первый вариант безопаснее, а второй быстрее и может значительно ускорить процесс обновления для больших баз данных.

Для обновления с версии Postgres Pro, основанной на этом же основном выпуске PostgreSQL, выгрузка/восстановление данных не требуется. Но вместо pg_upgrade вы должны использовать скрипт pgpro_upgrade, входящий в состав этого дистрибутивного набора. Этот скрипт обновляет метаданные как требуется в связи с изменением формата номера каталога, произошедшим после Postgres Pro 9.6.4.1. Если вы обновляете инсталляцию Postgres Pro, используя бинарный пакет, скрипт pgpro_upgrade запускается автоматически, либо вам предлагается запустить его вручную.

Важно

Если вы запускаете pgpro_upgrade вручную, вы должны остановить службу postgres. Этот скрипт должен запускать пользователь-владелец базы данных (обычно postgres). При попытке запустить pgpro_upgrade от имени root произойдёт ошибка.

Если вы скомпилировали Postgres Pro из исходного кода или создали базу данных в нестандартном расположении, вы должны запустить скрипт pgpro_upgrade вручную.

Примечание

В дистрибутивах Linux с системой пакетов RPM при обновлении с версии 9.6.2.1 или более ранней вы должны переименовать каталог данных pgsql в pgpro до запуска скрипта pgpro_upgrade.

Для перехода с ванильной версии PostgreSQL 9.6.x выполните выгрузку/восстановление данных, используя pg_dumpall.