Обсуждение: Speed in V8.0

От:
"Thomas Wegner"
Дата:

Hello, i have a problem between V7.4.3 Cygwin and
V8.0RC2 W2K. I have 2 systems:

1. Production Machine
    - Dual P4 3000MHz
    - 2 GB RAM
    - W2K
    - PostgreSQL 7.4.3 under Cygwin
    - i connect to it over a DSL Line
2. Develop Machine
    - P4 1800MHz
    - 760 MB RAM
    - PostgreSQL Native Windows
    - local connection 100MB/FD

Both systems use the default postgresql.conf. Now the problem.
I have an (unoptimized, dynamic) query wich was execute on the
production machine over DSL in 2 seconds and on my develop
machine, connected over local LAN, in 119 seconds!

Whats this? I can not post the query details here public, its a commercial
project. Any first idea? I execute on both machine the same query with
the same database design!
---------------------------------------------
Thomas Wegner
CabrioMeter - The Weather Plugin for Trillian
http://www.wegner24.de/cabriometer



От:
"Matt Clark"
Дата:

Another man working to the bitter end this Christmas!

There could be many reasons, but maybe first you should look at the amount
of RAM available?  If the tables fit in RAM on the production server but not
on the dev server, then that will easily defeat the improvement due to using
the native DB version.

Why don't you install cygwin on the dev box and do the comparison using the
same hardware?

M

> -----Original Message-----
> From: 
> [mailto:] On Behalf Of
> Thomas Wegner
> Sent: 21 December 2004 23:03
> To: 
> Subject: [PERFORM] Speed in V8.0
>
>
> Hello, i have a problem between V7.4.3 Cygwin and
> V8.0RC2 W2K. I have 2 systems:
>
> 1. Production Machine
>     - Dual P4 3000MHz
>     - 2 GB RAM
>     - W2K
>     - PostgreSQL 7.4.3 under Cygwin
>     - i connect to it over a DSL Line
> 2. Develop Machine
>     - P4 1800MHz
>     - 760 MB RAM
>     - PostgreSQL Native Windows
>     - local connection 100MB/FD
>
> Both systems use the default postgresql.conf. Now the
> problem. I have an (unoptimized, dynamic) query wich was
> execute on the production machine over DSL in 2 seconds and
> on my develop machine, connected over local LAN, in 119 seconds!
>
> Whats this? I can not post the query details here public, its
> a commercial project. Any first idea? I execute on both
> machine the same query with the same database design!
> ---------------------------------------------
> Thomas Wegner
> CabrioMeter - The Weather Plugin for Trillian
> http://www.wegner24.de/cabriometer
>
>
>
> ---------------------------(end of
> broadcast)---------------------------
> TIP 4: Don't 'kill -9' the postmaster
>


От:
Ragnar Hafstað
Дата:

On Wed, 2004-12-22 at 00:03 +0100, Thomas Wegner wrote:
> Hello, i have a problem between V7.4.3 Cygwin and
> V8.0RC2 W2K. I have 2 systems:
>
> 1. Production Machine
>     - Dual P4 3000MHz
>     - 2 GB RAM
>     - W2K
>     - PostgreSQL 7.4.3 under Cygwin
>     - i connect to it over a DSL Line
> 2. Develop Machine
>     - P4 1800MHz
>     - 760 MB RAM
>     - PostgreSQL Native Windows
>     - local connection 100MB/FD
>
> Both systems use the default postgresql.conf. Now the problem.
> I have an (unoptimized, dynamic) query wich was execute on the
> production machine over DSL in 2 seconds and on my develop
> machine, connected over local LAN, in 119 seconds!

has the development database been ANALYZED ?

gnari



От:
"Thomas Wegner"
Дата:

Thats was it. Now the speed was ok. Thank you.
---------------------------------------------
Thomas Wegner
CabrioMeter - The Weather Plugin for Trillian
http://www.wegner24.de/cabriometer

"Ragnar "Hafsta�"" <> schrieb im Newsbeitrag
news:...
> On Wed, 2004-12-22 at 00:03 +0100, Thomas Wegner wrote:
>> Hello, i have a problem between V7.4.3 Cygwin and
>> V8.0RC2 W2K. I have 2 systems:
>>
>> 1. Production Machine
>>     - Dual P4 3000MHz
>>     - 2 GB RAM
>>     - W2K
>>     - PostgreSQL 7.4.3 under Cygwin
>>     - i connect to it over a DSL Line
>> 2. Develop Machine
>>     - P4 1800MHz
>>     - 760 MB RAM
>>     - PostgreSQL Native Windows
>>     - local connection 100MB/FD
>>
>> Both systems use the default postgresql.conf. Now the problem.
>> I have an (unoptimized, dynamic) query wich was execute on the
>> production machine over DSL in 2 seconds and on my develop
>> machine, connected over local LAN, in 119 seconds!
>
> has the development database been ANALYZED ?
>
> gnari
>
>
>
> ---------------------------(end of broadcast)---------------------------
> TIP 5: Have you checked our extensive FAQ?
>
>               http://www.postgresql.org/docs/faqs/FAQ.html
>



От:
"Thomas Wegner"
Дата:

Ok, i installed the 7.4.3 on the dev machine under
Cygwin and the was 4 times slower than the V8.
They need 394 seconds. Whats wrong with my dev
machine. There was enough free memory available.
---------------------------------------------
Thomas Wegner
CabrioMeter - The Weather Plugin for Trillian
http://www.wegner24.de/cabriometer

""Matt Clark"" <> schrieb im Newsbeitrag
news:014001c4e9c8$266ec0a0$8300a8c0@solent...
> Another man working to the bitter end this Christmas!
>
> There could be many reasons, but maybe first you should look at the amount
> of RAM available?  If the tables fit in RAM on the production server but
> not
> on the dev server, then that will easily defeat the improvement due to
> using
> the native DB version.
>
> Why don't you install cygwin on the dev box and do the comparison using
> the
> same hardware?
>
> M
>
>> -----Original Message-----
>> From: 
>> [mailto:] On Behalf Of
>> Thomas Wegner
>> Sent: 21 December 2004 23:03
>> To: 
>> Subject: [PERFORM] Speed in V8.0
>>
>>
>> Hello, i have a problem between V7.4.3 Cygwin and
>> V8.0RC2 W2K. I have 2 systems:
>>
>> 1. Production Machine
>>     - Dual P4 3000MHz
>>     - 2 GB RAM
>>     - W2K
>>     - PostgreSQL 7.4.3 under Cygwin
>>     - i connect to it over a DSL Line
>> 2. Develop Machine
>>     - P4 1800MHz
>>     - 760 MB RAM
>>     - PostgreSQL Native Windows
>>     - local connection 100MB/FD
>>
>> Both systems use the default postgresql.conf. Now the
>> problem. I have an (unoptimized, dynamic) query wich was
>> execute on the production machine over DSL in 2 seconds and
>> on my develop machine, connected over local LAN, in 119 seconds!
>>
>> Whats this? I can not post the query details here public, its
>> a commercial project. Any first idea? I execute on both
>> machine the same query with the same database design!
>> ---------------------------------------------
>> Thomas Wegner
>> CabrioMeter - The Weather Plugin for Trillian
>> http://www.wegner24.de/cabriometer
>>
>>
>>
>> ---------------------------(end of
>> broadcast)---------------------------
>> TIP 4: Don't 'kill -9' the postmaster
>>
>
>
> ---------------------------(end of broadcast)---------------------------
> TIP 8: explain analyze is your friend
>