encoding problem at restore

Поиск
Список
Период
Сортировка
Искать
От
Bob Hunter
Тема
encoding problem at restore
Дата
Msg-id
6338.59322.qm@web31301.mail.mud.yahoo.com
Список
Дерево обсуждения
encoding problem at restore Bob Hunter <catdogbeloved@yahoo.com>
Re: encoding problem at restore Michael Fuhr <mike@fuhr.org>
Hello,

I have just updated to postgres8.1 and have the
following problem. The first line of the "PostgreSQL
database dump" 
says:

SET client_encoding = 'SQL_ASCII';

which is correct. However, the restore says:

ERROR:  invalid byte sequence for encoding "UTF8":
0xe02031
HINT:  This error can also happen if the byte sequence
does not match the encoding expected by the server,
which is controlled by "client_encoding".
CONTEXT:  COPY , line 1270


There are two problems. The first is, why UTF8 at all,
given that the dump specifies SQL_ASCII? The second
is, that at line 1270 there are (unsurprisingly) only
ASCII  characters, so why is psql complaining at all?

Thank you.

P.S. I am not subscribed, so please Cc the answers to me.


 
____________________________________________________________________________________
Yahoo! Music Unlimited
Access over 1 million songs.
http://music.yahoo.com/unlimited
В списке pgsql-general по дате отправления
От: Andrew Kirkness
Дата:
От: tonylaq
Дата:
FAQ