Re: BUG #3784: pg_ctl fails to start server when called with -c parameters
От
Tom Lane
Тема
Re: BUG #3784: pg_ctl fails to start server when called with -c parameters
Дата
Msg-id
2628.1196270860@sss.pgh.pa.us
Ответ на
BUG #3784: pg_ctl fails to start server when called with -c parameters (Stephen Bespalko)
Список
Дерево обсуждения
BUG #3784: pg_ctl fails to start server when called with -c parameters "Stephen Bespalko" <sjbespa@comcast.net>
Re: BUG #3784: pg_ctl fails to start server when
called with -c parameters Bruce Momjian <bruce@momjian.us>
Re: BUG #3784: pg_ctl fails to start server when called with -c parameters Tom Lane <tgl@sss.pgh.pa.us>
"Stephen Bespalko" writes: > The following start statement fails, after about 60 seconds: > bash-3.2$ > "/Users/sjbespa/Desktop/MDP.v8/MacDentPro/MacDentPro/build/Development/MacDe > ntPro 10.5.app/Contents/Resources/postgresql/bin/pg_ctl" -w -D > "/Users/sjbespa/pgsql.abqdental.8.2.intel.test/data" -l > "/Users/sjbespa/pgsql.abqdental.8.2.intel.test/postgresLogfile" -o '-p 7147 > -c log_line_prefix="t2453888748:r:" -c log_error_verbosity=VERBOSE -c > log_min_messages=INFO -c log_min_error_statement=INFO -c > log_connections=true -c log_disconnections=true' start > waiting for server to > start...............................................................could > not start server What I think happened here is that the postmaster started fine, but pg_ctl didn't know about the nonstandard port number and so was unable to contact it to verify that it was up. Did you look into postgresLogfile for messages? Usually the best bet for working with nondefault port numbers is to compile them into all the executables (configure --with-pgport=NNNN). Then everything Just Works and you don't have to think about it. If that's not workable then try "export PGPORT=NNNN". regards, tom lane
В списке pgsql-bugs по дате отправления