Re: PostgreSQL upgrade -> fails to start server

Поиск
Список
Период
Сортировка
Искать
От
Sander Smeenk
Тема
Re: PostgreSQL upgrade -> fails to start server
Дата
Msg-id
20030831053802.GD27825@freshdot.net
Ответ на
Список
Дерево обсуждения
Re: PostgreSQL upgrade -> fails to start server "Miquel van Smoorenburg" <miquels@cistron.nl>
Re: PostgreSQL upgrade -> fails to start server Sander Smeenk <ssm+pgsql@freshdot.net>
Quoting Miquel van Smoorenburg (miquels@cistron.nl):

> >| PANIC:  The database cluster was initialized with LC_CTYPE 
> >|         'nl_NL@euro.UTF-8', which is not recognized by setlocale().
> >|         It looks like you need to initdb.
> >Is there some way that I can get to my precious databases?
> 
> You have the source. Find where it prints this, make it not panic
> but continue, recompile, run that server, run psql, drop the indexes,
> dump the database.

Hey mike ;)
I know I /have/ the source. But I find it rather strange that I have to
/hack/ the source to have it start. 

I'm thankful for the postgresql people to protect me from damaging my
databases while i'm /not aware/ of the problem, but in this situation it
almost feels windows-like (no offence :P) since there is NO way to have
it start now, even if i really really really really really want it to.

I hope pgsql-devel people are reading, and willing to implement a system
like apt has when you want to remove something important like libc6:

| Please type the following line, without the quotation marks, to state
| that you really want this, and that you know what you're doing:
| "I know what i'm doing. Please let me damage my databases. I won't
|  complain on mailinglists, and I have recent backups."
|
| Repeat> 

btw, postgresql in Debian is built with doogies build system *shiver*

Sander.
-- 
| Chinese proverb: Do not meet girl in park, instead park meet in girl!
| 1024D/08CEC94D - 34B3 3314 B146 E13C 70C8  9BDB D463 7E41 08CE C94D
В списке pgsql-general по дате отправления
От: Alex
Дата:
Сообщение: SELECT Question
От: Kaarel
Дата:
FAQ