Postgres Pro Standard 9.6.3.1: примечания к релизу

Этот выпуск основан на PostgreSQL 9.6.3

В число ключевых усовершенствований по сравнению с Postgres Pro 9.6.2.1 входят:

  • Добавлено расширение pg_tsparser для текстового поиска.

    В дополнение к отдельным частям слова, возвращаемым по умолчанию, pg_tsparser также возвращает всё слово, если оно содержит:

    • подчёркивания

    • цифры и буквы, разделённые знаком минуса

  • Модуль pg_pathman обновлён до версии 1.3.2. Данная версия обеспечивает совместимость с текущим выпуском.

  • Модуль sr_plan теперь работает со значением search_path, отличным от стандартного.

  • Устранена ошибка с повреждением покрывающих индексов в WAL.

  • Добавлены дистрибутивные пакеты для SUSE Linux Enterprise Server 12 SP1 и Ubuntu 17.04.

  • Добавлены доработки для оптимизации наследования.

  • Доработка PTRACK обновлена до версии 1.2.

  • Представлены улучшения производительности для запросов, типичных для решений 1С.

Миграция на версию 9.6.3.1

Тем, кто хочет мигрировать данные из любой предыдущей основной версии, необходимо выполнить выгрузку/загрузку данных с помощью pg_dumpall или воспользоваться pg_upgrade.

Если используется версия 9.6.2.1, выгрузка/восстановление базы не требуется.

При обновлении c ванильного PostgreSQL 9.6.x требуется произвести некоторые изменения в каталоге.

Если вы используете бинарные пакеты, и ваша база данных расположена в стандартном месте, эти обновления будут выполнены автоматически. Если вы собираете Postgres Pro из исходных текстов или создаёте ваши базы данных в нестандартном месте, самостоятельно вызывая initdb, необходимо выполнить для этих баз скрипт pgpro_upgrade.

Перед запуском скрипта следует остановить сервис postgres. Скрипт должен запускать пользователь-владелец файлов базы (обычно postgres). В момент запуска переменная среды PGDATA должна указывать на обновляемую базу.