Postgres Pro Standard 12

Обзор

Этот выпуск основан на PostgreSQL 10.13 и Postgres Pro Standard 10.12.1. Все усовершенствования, унаследованные от PostgreSQL 10.13, перечислены в Замечаниях к выпуску PostgreSQL 10.13. Другие важные изменения и улучшения перечислены ниже:

  • Устранена утечка памяти, проявлявшаяся при операциях соединения, в которых требовалось оценивать множество путей выполнения для сложных запросов.

  • Добавлен параметр --no-data-checksums для initdb, позволяющий инициализировать кластеры Postgres Pro с отключёнными контрольными суммами.

  • Добавлена поддержка Oracle Linux 8.

  • Добавлена поддержка ОС Альт 8 СП.

  • Добавлена поддержка ОС Ubuntu 20.04; поддержка Ubuntu 19.04 прекращена.

  • Добавлен пакет plpython3 для ОС Rosa Enterprise Linux Server 7 и РОСА «КОБАЛЬТ» (серверная редакция) на платформе РОСА 7, а также для РЕД ОС 7 МУРОМ, Гослинукс 7 и AlterOS 7.5, где его раньше не было. Теперь он предоставляется для всех поддерживаемых платформ, кроме SLES 11 и МСВСфера 6.3.

  • Обновлено несколько библиотек, поставляемых с Postgres Pro для Windows, до следующих версий: OpenSSL 1.1.1g, libzstd 1.4.4, gettext 0.20.2, libiconv 1.16, libxml2 2.9.9 и libxslt 1.1.32. Библиотека ICU была обновлена с версии 56.1 до 56.2.

  • Расширение Раздел F.36 обновлено до версии 1.5.11. В данной версии устранена ошибка, возникавшая при попытке обращения к дочерним секциям, к которым нет доступа, при том, что к родительской таблице доступ разрешён. Эта проблема могла наблюдаться ранее при использовании pg_pathman с Postgres Pro 11.7.1 или новее.

Миграция на версию 10.13.1

Если вы производите обновление выпуска Postgres Pro Standard, базирующегося на той же основной версии PostgreSQL, достаточно просто установить новый выпуск в текущий каталог инсталляции.

Встроенные функции numeric_eq, numeric_ne, numeric_gt, numeric_ge, numeric_lt и numeric_le фактически являются герметичными, но они не имели соответствующей пометки в Postgres Pro Standard до версии 10.12.1, в результате чего запросы могли выполняться неоптимально. В частности, это отрицательно сказывалось на производительности запросов при использовании политик защиты на уровне строк. В версии 10.12.1 это было исправлено для новых инсталляций в результате корректировки исходных данных каталога, но существующие инсталляции сохранят некорректные пометки, пока вы не исправите записи этих функций в pg_proc. Чтобы их исправить, обновите экземпляр сервера с помощью pg_upgrade либо вручную измените их в существующем кластере, выполнив во всех его базах данных соответствующие команды ALTER FUNCTION. Например:

ALTER FUNCTION pg_catalog.numeric_eq VOLATILE

Начиная с Postgres Pro Standard 10.11.1, обновление версии ICU не препятствует запуску сервера. Перед подключением к базе данных, правило сортировки по умолчанию в которой использует ICU, Postgres Pro сравнивает версию этого правила сортировки с версией, предоставляемой библиотекой ICU, и выдаёт предупреждения в случае несовпадения версий; если вы полагаете, что изменение версии правила сортировки может повлиять на порядок сортировки ваших данных, перестройте объекты, использующие правило сортировки по умолчанию. Чтобы убрать эти предупреждения, вы можете выполнить команду ALTER COLLATION "default" REFRESH VERSION, как описано в ALTER COLLATION.

Так как в Postgres Pro Standard 10.7.1 была изменена модель распространения pg_probackup, при переходе с предыдущей версии в системе на базе Debian и ALT Linux выполните apt dist-upgrade (или apt-get dist-upgrade), чтобы корректно обработались все новые зависимости. В Windows для завершения обновления вам нужно будет запустить отдельный инсталлятор pg_probackup.

При обновлении с версии 10.3.2 и ниже вы должны выполнить команду REINDEX для индексов, в которых используются типы mchar или mvarchar. Кроме этого, если вы использовали pg_repack в системах на базе Debian, при переходе на эту версию вы должны будете переустановить соответствующий пакет вручную, так как он был переименован в pg-repack-std-10.

Для перехода с PostgreSQL или выпуска Postgres Pro Standard, базирующегося на предыдущей основной версии PostgreSQL, обратитесь к инструкциям по миграции на версию 10. Если вы выбираете вариант с выгрузкой/восстановлением данных, обязательно используйте параметр --add-collprovider, чтобы в восстановленной базе данных оказался корректный провайдер основного правила сортировки.