Re: BUG #9472: pg_dumpall fails with "unrecognized node type: 650"

Поиск
Список
Период
Сортировка
Искать
От
Tom Lane
Тема
Re: BUG #9472: pg_dumpall fails with "unrecognized node type: 650"
Дата
Msg-id
18131.1394212597@sss.pgh.pa.us
Ответ на
Список
Дерево обсуждения
BUG #9472: pg_dumpall fails with "unrecognized node type: 650" Wilfried.Weiss@nsg.com
Re: BUG #9472: pg_dumpall fails with "unrecognized node type: 650" Tom Lane <tgl@sss.pgh.pa.us>
Re: BUG #9472: pg_dumpall fails with "unrecognized node type: 650" "Weiss, Wilfried" <Wilfried.Weiss@nsg.com>
Re: BUG #9472: pg_dumpall fails with "unrecognized node type: 650" Noah Misch <noah@leadboat.com>
Wilfried.Weiss@nsg.com writes:
> pg_dumpall: query failed: ERROR:  unrecognized node type: 650
> pg_dumpall: query was: SELECT datname, coalesce(rolname, (select rolname
> from pg_authid where oid=(select datdba from pg_database where
> datname='template0'))), pg_encoding_to_char(d.encoding), datcollate,
> datctype, datfrozenxid, datistemplate, datacl, datconnlimit, (SELECT spcname
> FROM pg_tablespace t WHERE t.oid = d.dattablespace) AS dattablespace FROM
> pg_database d LEFT JOIN pg_authid u ON (datdba = u.oid) WHERE datallowconn
> ORDER BY 1

That's very bizarre.  The implication of the error message is that
something examining a query parsetree found a Value node where it
wasn't expecting one.  Ordinarily I'd think a parser or planner bug,
but since this is a standard query in pg_dumpall, it's hard to see
how such a bug could have escaped notice.  Another possible theory
is system-catalog corruption, but I don't see how that would explain
this particular symptom.  I wonder if you've got a corrupted postgres
executable.

In any case, since you're running a version that's a year or two
obsolete, updating to 9.2.latest would be a good first step.

> What can I do to be able to unload the data again?

If upgrading doesn't help, I'd try telling pg_dumpall to connect
to a different database initially (see -d option).  If it is some
bizarre species of catalog corruption, it probably is affecting
the postgres database only, so this might dodge the issue.

Failing that, try pg_dump'ing individual databases.

			regards, tom lane
В списке pgsql-bugs по дате отправления
От: Bruce Momjian
Дата:
От: Sergey Konoplev
Дата:
FAQ